Web Page not loading when searching for a Custom Field in Jira Administration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When searching for a custom field in the search field under Jira Administration > Issues > Custom Fields, the web page becomes unresponsive, causing it to get stuck as shown in the image below.

(Auto-migrated image: description temporarily unavailable)

Environment

Jira Data Center on any version from 8.0.0.

Diagnosis

  • Follow Generating HAR files and analyzing web requests to generate HAR file while reproducing the issue

  • HAR file can be loaded to browser for analysis by accessing the browser’s developer tools, navigate to the "Network" tab and upload the HAR file collected earlier

  • Look for the HTTP GET request made to the Jira REST API endpoint: 

    1 GET https://<jira-baseurl>/rest/api/2/customFields

    This request retrieves the details of custom fields configured in your Jira instance.

  • Select the identified HTTP GET request in the developer tools and click on the "Response" tab.

  • Locate the section related to the 'Problematic' custom field in the response. This will typically involve expanding the values section of the response.

  • The response should display detailed information about each custom field, including the customfield ID, name, description, and other metadata.

  • Pay special attention to the Description field of the custom field. It contains custom JavaScript code, which indicates a customization that is not part of the vanilla (out-of-the-box) Jira instance.

    (Auto-migrated image: description temporarily unavailable)
  • Once you identified the "Problematic" Custom Field, take note of:

    • its ID (the ID is the XXXXX number located after "customfield_" in customfield_XXXXX) - It will be useful for the Solution 1

    • its name - It will be useful for the Solution 2

Cause

The issue occurs because the script added to the custom field description interrupts the page loading, preventing the custom field details from being displayed properly in the Jira UI.

Solution

Solution 1: Resolve via the Jira UI

  • Navigate to the URL below, after replacing <XXXXX> with the Custom Field ID (the ID should have been identified during the diagnostics steps):

    1 <JIRA_BASE_URL>/secure/admin/EditCustomField!default.jspa?id=<XXXXX>
  • Remove the content from the description field, especially any script present.

  • Click Update to save the changes.

Solution 2: Resolve via Database (if the page does not load)

If the custom field is not visible or the page fails to load, you can remove the script from the database directly, by following the steps below:

  • Stop the Jira application

  • Take a backup of Jira database

  • Use the query below to clear the description field of the "Problematic" custom field, after replacing <Customfield-name> with the name of the custom field (the name should have been identified during the diagnostics steps):

    1 update customfield set description = null where cfname = '<Customfield-name>';
  • Start the Jira application

Updated on March 19, 2025

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