Users are unable to view/download attachments from email notification

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When an email notification is sent to users with attachments, they are unable to view or download them from the notification as they appear as text:

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Environment

Jira Service Management Cloud

Diagnosis

  1. Open the field configuration for the affected project by going to Cogwheel > Issues > Field configuration.

  2. Click Configure next to it and search for the field "Comment".

  3. You will notice that the field "Comment" is updated with "Default text Renderer" in the Field Configuration

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Cause

The "Comment" field needs to use "Wiki Style Renderer" to display the attachments AS IS and hence, allow them to be downloaded. When configured as Text rendered, the attachments will be displayed in the textual format and hence cannot be used for viewing/downloading.

Solution

  1. Click Renderersnext to the field Comment to update.

  2. Select Wiki style renderer from the Active Renderer list and click Update.

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Note

Changing the renderer will affect the display of all issues associated with this field configuration. The renderer can always be changed back and the view will be as it was before.

Updated on April 15, 2025

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