Users are unable to rank issues on Jira boards

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to rank issues on a Jira Board by dragging and dropping them, the error below is shown in the UI:

1 Ranking is disabled, as the Filter Query for this board is not ordered by ascending Rank. Please check your filter configuration.
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Diagnosis

Diagnosis for Root Cause 1

Check the Field Configuration associated to the project the issue belongs to, and search for the Rank field. If it is configured to be hidden, then this root cause is relevant.

Diagnosis for Root Cause 2

Go to the Board general configuration. If the message below appears, then this root cause is relevant:

1 Ranking is disabled, as the Filter Query is not ordered by Rank

Cause

Root Cause 1

The Rank field is probably hidden in the Field Configuration associated to the project the issue belongs to.

Root Cause 2

Ranking is disabled for the board, due to the JQL query configured for the board.

Resolution

Resolution For Root Cause 1

Click on Show in the Rank field options in the Field Configuration to enable it.

Resolution For Root Cause 2

Go to Board general configuration and click on the Add Rank button.

Updated on April 10, 2025

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