Users are able to download Jira attachments even after they have been deleted

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Users have deleted attachments from issues but are still able to download the attachment via the original download URL for that file, for example:

However, different users are not able to access the file when navigating to the link, but affected users can confirm that it starts a download for them.

Diagnosis

Usually, this behavior is caused by either browser or a load balancer cache. So when you click on the URL again it just downloads the file from its local cache.

You can test this by following the steps below:

  1. Add an attachment to a Jira issue;

  2. Download the file;

  3. Now do a right-click anywhere on the page and select Inspect, then go to the Network tab and check Disable Cache

  4. Delete the file and try download it again, you should be redirected to a 404 page

So that pretty much affects only users who have downloaded the attachment and in a short amount of time, until the browser has expired the cache for that file. If they close and reopen the browser it should also clear the cache.

If the problem persists in your case, it might be caused by the load balancer or reverse proxy.

Updated on April 8, 2025

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