Usernames with Umlaut characters cannot log in or be deleted in JIRA

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Users with Umlaut characters in their usernames cannot log in or be deleted in JIRA. There are no errors in the log files.

In the UI, we can see the following "User Does Not Exist" error:

(Auto-migrated image: description temporarily unavailable)

Cause

The Apache Tomcat connector was not configured with UTF-8 encoding.

Resolution

  • Check the server.xml file found in $JIRA_INSTALLATION/conf/

  • A standard connector may have the following configuration:

    1 2 3 4 <Connector port="8080" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8443" URIEncoding="UTF-8" />

    In this case, the URIEncoding has been correctly set to UTF-8.

  • In this example, the AJP Connector does not have any URIEncoding parameter set:

    1 <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />

    Simply add the URIEncoding parameter like so:

    1 <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" URIEncoding="UTF-8"/>
  • Once done, restart JIRA and the problem should be fixed.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.