Username is Displayed in Issue View Page After Upgrade JIRA

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

In the Issue View page, the Assignee and the Reporter fields are displaying the username instead of the Display Name or Full Name for the user.

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Diagnosis

  • In cwd_user table, there are users with mixed case usernames and mix letters and numbers usernames.

  • Run the following SQL query against JIRA database to check the value for Assignee and Reporter for the particular issue. Replace <issuekey> with the affected issue's issuekey.

1 select * from jiraissue where pkey='<issuekey>';

Cause

  1. This appear to also caused by bad collation configuration during database creation. Please verify the collation type, for example in MySQL

  2. There are values for Assignee and Reporter column in jiraissue table which is mapped to the upper case letters where it should be using the lower case letters.

Solution

Resolution #1

Please verify the database's collation has been configured correctly referring to Connecting JIRA to a Database following your database server respectively. Example in MySQL, you can verify the collation type using the following:

1 select table_collation from information_schema.tables where table_name = 'jiraissue' and table_schema = 'jiradb';

If the database's collation is not configured correctly, please update them accordingly with reference to the documentation above.

Resolution #2

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Shutdown JIRA

  2. Create a database backup

  3. Run the following fix

    1 2 UPDATE jiraissue SET reporter=LOWER(reporter); UPDATE jiraissue SET assignee=LOWER(assignee);
  4. Restart JIRA

  5. Re-index JIRA

Updated on April 8, 2025

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