Username changes to all caps after logging in

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After logging into an instance if JIRA, the user's username changes from lowercase characters to uppercase characters.

For example, the username was fluffhead123 prior to login. After login, the username appears as FLUFFHEAD123.

Cause

This is caused by JIRA's integration with an LDAP directory for delegated authentication. In some cases, organizations will have a user provisioning process where an account is created in JIRA before it is created in their LDAP server. The account's username could be entered into JIRA as fluffhead123, but when the LDAP account is created, it has FLUFFHEAD123 listed as its relative distinguished name (username). When the user logs in, their account is then updated with the all caps version of their username. Because most LDAP systems and are not case sensitive, the user can still log in with the lower case version of their username.

The change in username casing does not have a major impact on the performance of any of JIRA's core functionality with the noted exception of any Activity Stream gadgets that have been configured to filter on a specific username. This gadget is, at the time of this writing, case sensitive and will stop pulling activity records for that user.

Resolution

ℹ️ As noted, the change in username casing should not present problems with core JIRA functionality. Since LDAP systems are frequently used as the systems of record within an organization, a JIRA admin who finds themselves in this situation needs to reach out to the administrators of the relevant LDAP system for more information.

Updated on April 8, 2025

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