User is unable to see Manage app/Explore app section

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

For some of the users "Manage app" or "Explore app" section is not visible, additional some of the apps from "Your App" section are missing for them.

Environment

Jira cloud

Diagnosis

Ensure whether the users in question hold "Product admin" permission on the "Jira administration" product.

Cause

The user does not hold the required permissions to access the "Manage App" or "Explore App" sections. If the app was recently installed, non-admin users would not be able to see it via the "Your app" tray.

Solution

If a user having Product admin access installed an app they would be able to view installed app in "Your app section" as admin could view. 

However, if any user is not an admin and hasn't accessed the app in question in the past, then they would neither be able to access the "manage app" section because they are not part of the "Jira Administration" product access nor able to view the App installed as they never accessed the app. 

If you wish to give the user access to "manage app," please consider providing them with this access and then removing it. The user should be able to view the app in the "Your app" section.

Updated on March 6, 2025

Still need help?

The Atlassian Community is here for you.