User details from User Management shows Application access checkbox as unchecked despite user having access to the application
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When viewing a user's details by navigating to Jira Administration > User Management > Users and clicking on the username, the Application access checkbox under Applications and groups section is shown as unchecked:

However, the main Users page under Jira Administration > User Managementshows that user has access to the application:

Diagnosis
Check what are the default groups of the application under Jira Administration > Applications > Application access:

Then verify if the user is part of all of them or just of some:

In the example above can be seen that "Jira Software" application has two default groups (developers and jira-software-users), but the user is part of one of them only (jira-software-users).
Cause
This is the intended behaviour.
If the Application access checkbox is unticked, it doesn't mean that user doesn't have access to the application as it is enough for the user to be part of any group which grants the access.
Instead, ticking the Application access checkbox means that the user is added to all the default groups of that application.
If the user is not part of all the default groups, the checkbox remains unchecked.
For more details on how application access and default groups work, please refer to Manage group access to applications.
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