User custom fields are returning blank values in the notifications received for the users.

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When an update is made on the custom field, the email notification comes through and the updated custom fields shows blank entries.

It doesn't show what has been updated or changed in the custom fields.

Environment

Jira Cloud

Diagnosis

  • Checked the issue in Jira for this case and can see that the fields are updated with values correctly.

  • It was noted that any update we make on Jira on the below custom fields, the Jira notification come through to all watchers as blank.

Cause

This bug was caused by the customer using the old email template in the instance. This was a result of using a customized domain for the email address in the project's notification.

This can be verified under Project > notifications for the concerned project. 

Please see the bug report here: JRACLOUD-79775 - Custom created user picker field value was empty in the email notifications

Solution

The workaround suggested here is: To use the default domain of the atlassian.net and see if the email notifications are coming up with the value for the custom field.

Updated on February 25, 2025

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