User account is Inactive in JIRA after it was re-activated on Active Directory

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

User was made Active again in AD after having been inactivated, but is still showing as inactive in Jira

Environment

8.13.2

Diagnosis

  • User is active in the AD environment.

  • User is able to log into other applications with their AD credentials, but is unable to access Jira.

  • Results of the following query return the active column set to zero:

1 select * from cwd_user where user_name='<USERNAME>';

Cause

User was made inactive in AD, then changed back to active, but the Jira database table cwd_user was not updated to indicate that the user is now active again

Solution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Stop Jira.

  2. Update the user in the cwd_user table to active with the following query:

    1 update cwd_user set active=1 where user_name='<USERNAME>';
  3. Restart Jira.

Updated on April 2, 2025

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