Resolve Incompatibility Issues for Upgraded Apps in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After upgrading a third-party app, a message is shown saying the app is "Installed but incompatible".

Diagnosis

Change the logging

  • Navigate to Administration ⚙ > System

  • Select System support > Logging & Profiling to open the Logging page

  • Search for com.atlassian.plugin and set to DEBUG

Try the upgrade

  • Run the upgrade of the app

  • Check the log file atlassian-jira.log, which is located in the log Subdirectory of your Jira application home directory

  • You will see a message of the following type:

/rest/plugins/1.0/installed-marketplace [c.a.plugin.manager.DefaultPluginManager] Duplicate plugin found (installed version is newer): 'com.xxxx.plugins.xxxx'

Cause

It's unclear what exactly is causing this issue, but it appears that Jira is not able to recognize that the updated version is newer than the currently installed one.

As a result, it fails to perform the necessary update.

Solution

Uninstall and reinstall the affected app.

Updated on May 21, 2025

Still need help?

The Atlassian Community is here for you.