Upgrade Jira 5.2.x to 6.1.x will creates a new Customer Request Type field after restart Jira
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptom
Service Management will creates a new Customer Request Type field when Jira restart.
Diagnosis
This problem only happen when you run Service Management plugin v1.1.1 on Jira 6.1.x after performing the upgrading process.
There is an existing bug report logged on this - JSDSERVER-268 - Service Desk creates a new Customer Request Type field (vp-origin) every time it starts
Workaround
Disable the Service Management plugin in Jira 5.2.x and generate the backup.
In Jira 6.1.x, you can try the following options to upgrade ServiceDesk plugin:
Navigate to Add-Ons administration page > Upload Jira ServiceDesk 1.2.5 Plugin (manually) > Enable Jira SeviceDesk Plugin
Copy ServiceDesk latest jar file to $Jira_HOME/plugins/installed-plugins and start Jira
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