Updating request type fails in automation

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

AThe automation rule fails to edit the "Request Type" field with the following error:

Field 'customfield_xxxxx' cannot be set. It is not on the appropriate screen, or unknown. (customfield_xxxxx)

Diagnosis

This issue generally occurs if the "Request Type" field is not added to the "Edit screen" of the Issue type. However, this error is also caused if there are two "Request type" fields with the same configuration found in the Custom fields.

Cause

The 2 "Request type" fields found are:

  • The main field "Request Type" isthe one that the automation rule should have updated but it is referring to the other one.

  • The "Requesttype" is the one with the description: "Request type created by JIM during import process". This field is created during Migration/Import.

Usually, the backend uses the main request type created by the Jira Service Management but on the UI, the system tries to set a different field.

Solution

To fix this concern, you need to Delete the "Request type" field created by JIM during the import process permanently. To delete the field, refer to the below steps:

  1. Select Settings > Issues.

  2. Under FIELDS, select Custom fields.

  3. Search for the field "Request type" created during the import process >>click on More (three dots) > select Move to Trash

  4. Now select the "Trashed" tab from the top and select Actions (…) > Permanently delete.

Permanently deleting a custom field also deletes all the data stored against that field. You can’t undo this. If you want to keep field data for historical records, we recommend you back up your Jira site before permanently deleting fields. Learn more about backing up your Jira site.

Last, go to your Jira Automation Rule, delete the edit request type action, add it again, configure it, and publish the changes. 

Updated on March 5, 2025

Still need help?

The Atlassian Community is here for you.