Resolve Universal Plugin Manager Firewall Issues in Jira

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Administrators are unable to use the Universal Plugin Manager because of a firewall configuration preventing downloads.

Cause

The Universal Plugin Manager makes calls to plugins.atlassian.com for metadata about the plugins installed. In order to pull down updates for the installed plugins, it contacts the various different repositories in which the plugin developers publish their plugins.

Workaround

Administrators can download plugins manually from the plugin exchange, then upload them from the JIRA server (via Administration >> Add-ons.

Resolution

  1. As plugins.atlassian.com is a dynamic community of developers that undergoes constant improvement and change, it's very difficult to provide a static list of servers to whitelist for a static firewall. An initial configuration, to allow the plugins supported or hosted by Atlassian, is to open these repositories:

    https://maven.atlassian.com https://marketplace.atlassian.com
  2. If your firewall needs specific IPs for whitelisting, you can ping both addresses above as the IP for those URLs are not static at this point in time. You 'll want to run the following in a command prompt or terminal to get the according IPs.

    ping maven.atlassian.com ping marketplace.atlassian.com

For more information see Configure Web Proxy Support for JIRA.

ℹ️ See the workaround above to understand about how to download plugins manually.

Updated on June 12, 2025

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