"Uncaught Error: raven/autocomplete/model missing backbone" when creating or moving issues via Agile boards in Jira Server and Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When creating issues or moving them between columns in Agile boards, the error Exception: Uncaught Error: raven/autocomplete/model missing backbone occurs.

Environment

Jira Data Center 9.x

Diagnosis

  • The following JavaScript error appears when creating or moving issues in Agile boards:

    1 2 3 4 5 6 7 8 9 Please try refreshing the page, or contact your administrator / Atlassian Support if the problem continues. Details Exception: Uncaught Error: raven/autocomplete/model missing backbone Line: 10 Column: 1974 Environment Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/119.0.0.0 Safari/537.36 Stack trace Error: raven/autocomplete/model missing backbone
  • Go to the page ⚙ > Manage Apps > Manage App:

    • Check if the add-on "Xray Test Management for Jira" is listed

    • If it is, try to disable it and check if the error is resolved

    • If the error is resolved, then this KB article is relevant and you can move on to the Solution section

Cause

This error is caused by the Xray Test Management for Jira third-party plugin.

Solution

  1. Navigate to the page ⚙ > Manage Apps > Manage App and upgrade the add-on "Xray Test Management for Jira" to the latest version

  2. If the error still occurs after the Xray plugin has been upgraded, contact the plugin vendor Xblend for support.

⚠️ We have seen reports that uninstalling and reinstalling the Xray app has resolved the issue as well if it is installed. However it is recommended to still contact Xblend for support to confirm this path.

Updated on April 11, 2025

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