Unassigned issues doesn't follow the swimlane configuration

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Setting the "Unassigned" issues to be shown on the "Top" or "Bottom" in the swimlane configuration seems to have no effect. These issues are still being listed in the alphabetic order.

Cause

Verify if there is an user named "Unassigned" exists within JIRA. This will cause JIRA Agile to treat "Unassigned" as an user and sort in the alphabetical order instead of obeying the swimlane configuration.

  • To check your users listing: (JIRA Administration -> User Management -> Users)

Resolution

Option 1: Remove the "Unassigned" user

  1. Log into JIRA as an Administrator

  2. Bulk-edit all issues assigned to the "Unassigned" user to another user

    1. https://confluence.atlassian.com/display/JIRA/Modifying+Multiple+('Bulk')+Issues

  3. Navigate to Administration > User Management > Users

  4. Remove the "Unassigned" user

Option 2: Rename the user

This problem is related to a third party plugin, and therefore not supported by Atlassian. See Atlassian Supported Plugins for more information.

  1. Log in to JIRA as an Administrator;

  2. Browse through Administration -> Plugins -> Find new Add-Ons;

  3. Search for Script Runner and Install the plugin;

  4. After the plugin is installed, click on the "Administration" tab;

  5. Search for "Builtin Scripts" and click on it;

  6. Search for "Renames a User ID";

    1. On "From User ID" field, type the name of the current user "Unassigned";

    2. On "To User ID" field, type the name of a temporary new user;

    3. Select the radio button "Rename" and click on "Run";

  7. Now the user will be renamed and all the issues assigned to the user "Unassigned" are now really unassigned;

  8. Search for the user you've just renamed and now you will be able to delete it;

Updated on April 8, 2025

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