Unable to view issues from the Traceability tab of Zephyr.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Jira user gets getting following warning while accessing the Traceability tab in the Zephyr plugin test case.

1 issue is not being displayed. Maybe you don't have permission for viewing this issue or it has been deleted.

Environment

  • Jira v8.13.13 or higher

Diagnosis

On reviewing the HAR file collected when the warning is observed, there is a call being made to Jira from plugin requesting for the contents of the endpoint:

  • <JIRA URL>/rest/api/2/search

From the response, which requests the Jira issues there is an empty response like below

Response code

1 {"startAt":0,"maxResults":0,"total":1,"issues":[]}

Cause

The empty response for issue like observed above is caused if jira.search.views.default.max property under Advanced settings set to 0, which results in all REST requests for issue search returning 0 results. Some similar behavior is tracked in a known bug:

Solution

  • Set the jira.search.views.default.max value to 1000 (default).

  • Navigate to ⚙ > General configuration > Advanced Settings.

  • Set the Key jira.search.views.default.max value to 1000.

Updated on April 11, 2025

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