Unable to use PAT token to authenticate REST API calls - Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Users encounter an error stating "PAT tokens are disabled" when attempting to authenticate API calls using Personal Access Tokens in Jira.

Environment

All versions of Jira Software and Jira Service Management Data Center.

Diagnosis

  • In the application logs, the following error message is observed while executing the API calls using the Personal Access Tokens:

    logs

    1 2024-06-25 16:10:43,434+1000 http-nio-82-exec-19 ERROR anonymous 970x586299x1 - 10.20.xx.xx /rest/api/2/myself [c.m.r.a.commons.handler.ApiKeyAuthenticationHandler] No user found
  • On the user end, getting the "PAT tokens are disabled" error as shown in below screenshot:

    (Auto-migrated image: description temporarily unavailable)
  • Able to execute the API calls using basic authentication without any issues.

Resolution

The issue stems from a specific setting within this third-party app: Enhance API Security for Jira REST APIs with OAuth/API Token, which, when disabled, blocks the use of PAT tokens in Jira.

(Auto-migrated image: description temporarily unavailable)

By enabling PAT tokens through the app settings, users should be able to authenticate their API calls successfully using Personal Access Tokens.

Updated on April 10, 2025

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