Unable to switch Issue Type Scheme due to inactive users

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

When trying to change the Issue Type Scheme of a particular project with a relatively large amount of issues (10,000+) and a number of inactive users is around 20+, the screen hangs when migrating the Issue Type. As an example, migrating from Sub-tasks to Technical Tasks

Diagnosis

The process is taking a very long time and eventually, it hangs. At the same time, the user will also experience session timeout.

Cause

As of now, the possible reason behind this matter is that it is caused by the number of inactive users / groups (reporters, assignees, etc.) in the project itself.

Solution

Workaround

  1. Make changes to the Permission Scheme by granting the Create Issue and Assignable User permission to the inactive user / group.

  2. After that, proceed with changing the Issue Type Scheme of the project. By now, the process should run smoothly without any problems.

  3. Finally, you should be able to remove the inactive users from the Permission Scheme again.

Updated on April 8, 2025

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