Unable to send email after using Support Tools

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Symptom 1:

After using Support Tools Plugin to send a support request, the mail queue will stop functioning and email cannot be sent out anymore.

The following appears in the atlassian-jira.log:

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 2012-04-23 12:19:39,667 http-8080-2 WARN admin 739x38947x1 14n0wy5 127.0.0.1 /plugins/servlet/stp/view/create-support-request/execute [support.tools.salext.WildcardApplicationFileBundle] The file /opt/atlassian/jira/logs/manager.2011-08-02.log does not contain any data, and was skipped. 2012-04-23 12:19:39,667 http-8080-2 WARN admin 739x38947x1 14n0wy5 127.0.0.1 /plugins/servlet/stp/view/create-support-request/execute [support.tools.salext.WildcardApplicationFileBundle] The file /opt/atlassian/jira/logs/manager.2011-08-05.log does not contain any data, and was skipped. 2012-04-23 12:19:43,122 http-8080-2 ERROR [500ErrorPage.jsp] Exception caught in 500 page null java.lang.AbstractMethodError at java.util.PriorityQueue.siftUpComparable(Unknown Source) at java.util.PriorityQueue.siftUp(Unknown Source) at java.util.PriorityQueue.offer(Unknown Source) at java.util.concurrent.PriorityBlockingQueue.offer(Unknown Source) at java.util.concurrent.PriorityBlockingQueue.add(Unknown Source) at com.atlassian.mail.queue.MailQueueImpl.addItem(MailQueueImpl.java:105) at com.atlassian.support.tools.salext.mail.JiraMailUtility.queueEmail(JiraMailUtility.java:27) at com.atlassian.support.tools.salext.mail.AbstractMailUtility.sendMail(AbstractMailUtility.java:29) at com.atlassian.support.tools.request.CreateSupportRequestAction.execute(CreateSupportRequestAction.java:151) at com.atlassian.support.tools.SupportToolsViewServlet.displayResults(SupportToolsViewServlet.java:244) at com.atlassian.support.tools.SupportToolsViewServlet.doPost(SupportToolsViewServlet.java:96) ... 2012-04-23 12:19:55,024 QuartzWorker-0 ERROR ServiceRunner Mail Queue Service [atlassian.jira.service.ServiceRunner] An error occured while trying to run service 'Mail Queue Service'. null java.lang.NullPointerException at java.util.PriorityQueue.siftDownComparable(Unknown Source) at java.util.PriorityQueue.siftDown(Unknown Source) at java.util.PriorityQueue.poll(Unknown Source) at java.util.concurrent.PriorityBlockingQueue.poll(Unknown Source) at com.atlassian.mail.queue.MailQueueImpl.sendBuffer(MailQueueImpl.java:60) at com.atlassian.jira.service.services.mail.MailQueueService.run(MailQueueService.java:23) at com.atlassian.jira.service.JiraServiceContainerImpl.run(JiraServiceContainerImpl.java:60) at com.atlassian.jira.service.ServiceRunner.execute(ServiceRunner.java:47)

Symptom 2:

When attempting to create support request from the JIRA instance, an "Error retrieving results" occurs: Internal Server Error

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Cause

This is caused by a known bug within the Support Tools Plugin, as tracked within STP-138.

Workaround

  1. Disable Support Tools plugin

  2. Restart JIRA

Resolution

  1. Upgrade the Support Tools Plugin to the latest version, as this bug was fixed in 3.0.9.

  2. Restart JIRA.

As the mail queue is stored within JIRA's memory, any restart of the application will unfortunately lose that queue. Please keep this in mind that restarting JIRA will lose this queue. We have a new feature to persist the queue, as in JRASERVER-4665 - Need to persist Mail Queue Items

Updated on April 8, 2025

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