Unable to see tabs on screens for some users

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When viewing or editing a screen, some users might not be able to view the tabs for that screen but other users with similar permissions/groups/roles can still view the tabs.

For example, some users are able to view the following tabs on the screen:

(Auto-migrated image: description temporarily unavailable)

But for certain users, they will not be able to view the tabs:

(Auto-migrated image: description temporarily unavailable)

Cause

There are custom scripts designed to hide the fields/tabs on the field configuration. Note that custom scripts fall under customization in the Atlassian Support Offerings therefore Atlassian Support would not be able to assist in making the script work as you intended it to be.

Diagnose

  1. Run the following SQL query in your database to validate if you have any fields with custom scripts to hide the field:

    1 select id, fieldidentifier, description from fieldlayoutitem where description like '%.hide%';
  2. Go to the Field Configuration Scheme > Edit > Look for the missing fields that were supposed to appear on the tab and check for custom scripts

    • Below is an example on how the custom script might look like:

1 2 3 4 5 6 7 8 9 10 11 12 <script type="text/javascript"> (function($) { AJS.toInit(function(){ // init on load AJS.$("#qf-field-picker-trigger").hide(); }) JIRA.bind(JIRA.Events.NEW_CONTENT_ADDED, function (e, context) { // init on refresh AJS.$("#qf-field-picker-trigger").hide(); }); })(AJS.$); </script>

Resolution

Remove the custom scripts to allow the affected users to be able to view the tabs again.

Updated on April 8, 2025

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