Troubleshoot: Can't Save Automation Rule in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

You can't publish the automation rule. When you try, it stays in draft mode, and changes aren't applied.

Cause

  • The automation rule covers multiple projects.

    • You might not have access to all projects.

    • Some projects might be archived or deleted.

Solution

  • Open the automation rule details by navigating to Settings ⚙ > System

  • Select Global Automation.

  • Check if all the projects on the list under Scope are active.

  • Check for any deleted or archived projects under Projects.

  • Remove them to successfully publish your rule.

  • Click on Update, and the automation rule will be published successfully.

Updated on September 25, 2025

Still need help?

The Atlassian Community is here for you.