Unable to route the call to certain countries while using incoming call integration with Twilio

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

You have integrated incoming call routing with Opgenie using the Twilio number mentioned in Use a custom phone number from Twilio. However, while testing this integration, the call is not getting routed to certain countries (in this scenario, the Netherlands) from the Twilio account. 

Diagnosis

Analyzing Opsgenie logs, you notice the message (Settings > Debug > Logs):

1 [system] Couldn't dial 31-XXXXXXXX; reason: Code[21215]: Account not authorized to call +31XXXXXXXX. Perhaps you need to enable some international permissions: https://www.twilio.com/console/voice/calls/geo-permissions/low-risk

Cause

As part of the Voice Geographic Permissions on Twilio, the specific country needs to be enabled to perform the outgoing calls as mentioned in Twilio's documentation at Protect your account with Voice Dialing Geographic Permissions.

Solution

Verify and Enable the country where the call has to be routed according to the requirement.

Updated on March 12, 2025

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