Unable to read Jira JMX data in LogicMonitor
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When integrating LogicMonitor with Jira via JMX, attributes with the dot character (.) are not able to be read
Environment
Jira is integrated with Logic Monitor via JMX
Diagnosis
An an example, when reading the attribute jira-software.max.user.count
within LogicMonitor, only the jira-software
part is read
Cause
The behaviour occurs because LogicMonitor treats dots in an attribute as as a composite attribute instead of a single attribute. Unfortunately, many of Jira's attributes are denoted with dots, for example:
jira-software.max.user.count
issue.search.count
web.requests
Solution
Escape the dots in the Jira attribute with a backslash ("\") character. For example, jira-software\.max\.user\.count
For more information, please see LogicMonitor Documentation: JMX Data Collection Methods
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