Unable to rank issues after upgrading Jira Software

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Jira Agile cannot perform any rank operations (such as ranking issues, balancing) after upgrading JIRA Agile (from non lexorank to lexorank). For some reasons, the new rank is named Rank (Obsolete) and the old rank was named Rank (Obsolete) (Obsolete).

The following error message was thrown when users try to rank any issues

Jira Agile cannot execute the rank operation. This board has recently been configured to use the rank field. The system must be re-indexed before you can rank issues. Ask your administrator to perform a manual re-index.

The following appears in the atlassian-jira.log

2015-08-03 02:06:11,812 http-bio-8443-exec-473 WARN XXX 125x867891x1 15p7ntz XX.XX.XX.XXX /rpc/soap/jirasoapservice-v2 [greenhopper.customfield.lexorank.LexoRankCFType] Unable to retrieve rank for field [customfield_id] and issue [XXXXX] 2015-08-03 02:06:11,812 http-bio-8443-exec-473 WARN XXX 125x867891x1 15p7ntz XX.XX.XX.XXX /rpc/soap/jirasoapservice-v2 [greenhopper.customfield.lexorank.LexoRankCFType] gh.lexorank.service.error.retrytimeout

Please note there are other possible reasons for Jira to be unable to perform ranking operations.

Diagnosis

  1. Run the following queries to check the existing rank fields. Verify if the rank field names are correct. The expected behavior should be that JIRA will create a new Rank field name Rank and rename the old rank field as Rank (Obsolete)

    SELECT * FROM customfield WHERE customfieldtypekey like '%rank%';
  2. Run the following query to check the rank field used in lexorank

    SELECT propertyvalue FROM propertyentry LEFT JOIN propertynumber ON propertyentry.ID = propertynumber.ID WHERE property_key = 'GreenHopper.LexoRank.Default.customfield.id';
  3. Verify the Rank field referred in board filter. The board filter should use the rank field returned from the second query.

Cause

For some reasons, the new rank is named Rank (Obsolete) and the old rank was named Rank (Obsolete) (Obsolete). And JIRA is referring to Rank (Obsolete) as the default rank field. While the board is referring to Rank.

Solution

Resolution

At the moment, we have the following options to deal with the ranking problems within the boards:

  • Unlocking the Rank custom field (to be performed in the database) following this documentation How to unlock a Locked field and then rename the rank field from the UI, OR

  • Renaming the custom field directly in the database, as described below;

    1. Shutdown Jira

    2. Run this query to rename Rank custom field in your database

      UPDATE customfield SET cfname='Rank' WHERE id = customfield_id ;
    3. Restart Jira

    4. Test if you can rank the issues and perform issues transition in the board

    5. If you still face the same problem, kindly perform full re-indexing and test it again.

    Please shutdown Jira and generate backup before modifying the database.

Updated on May 22, 2025

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