Unable to quick search values contained in number custom fields

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When searching for issues through the Quick Search based on Number Custom Field values results in Jira being unable to find any issues.

Cause

When using the Quick Search, Jira will use a text search JQL.

1 text ~ '1234'

Custom Number fields are not classified as text fields and are therefor skipped by this JQL.

Workaround

Search for the issues by filtering based on the Custom field directly. For example, searching for a phone number contained in the custom number field “Phone”.

1 Phone = '123456789'

Resolution

Should being able to quick search be crucial to your operations, we suggest to create a new text field to store the values instead. Please see Using Workflow 'Regular Expression Check' Validator to Restrict Text Field in Number Format for more information.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.