Unable to load email templates after upgrading Jira

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Sometimes, after upgrading Jira to version 9.x, the email templates will not render anymore.

Environment

Jira Data Center on any version from 9.0.0.

Diagnosis

On trying to access the email templates in Jira it comes up with the following error: "We couldn't complete this action. Details: Directory [path to the $JIRA_HOME directory\data\templates\email_RevertTemp\css] could not be created.

The atlassian-jira.log files will include the following entries:

1 2 2023-07-09 11:37:48,665+0200 http-nio-127.0.0.1-8080-exec-1 ERROR username 697x106005x1 1bcpwkj 85.115.11.137,127.0.0.1 /rest/api/2/email-templates/revert [c.a.jira.template.DefaultMailTemplatesService] Templates operation started, but could not be finished due to an error. java.io.IOException: Directory '[JIRA_HOME_path\data\templates\email_RevertTemp\css' could not be created

Cause

File level permissions may have gotten reset during the upgrade 

Solution

Make sure the account that runs Jira has read-write access to to $JIRA_HOME folder

On Linux you can identify the account by running "ps -ef | grep jira" command

On Windows, if Jira runs as a service, open services.msc, navigate to the service properties and check the account that's configured to run Jira 

Updated on March 12, 2025

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