Resolve App Installation Errors on Jira Cloud OneAtlassian Sites
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
While installing a Marketplace app on OneAtlassian demo sites you encounter the following error:
We ran into a little trouble
Unfortunately, we're unable to process your request. Please retry again in some time.
Got it
You can fix these issues by following these steps.
Environment
Jira Software Cloud demo instance
Diagnosis
How to identify if the instance is a demo instance?
The billing contact will be provision-fy24-2-bot
Cloud instance URL will have ONE in the domain name "https://one-xxx.atlassian.net" or "https://xxx-one.atlassian.net"
Diagnosis Steps
You should generate HAR file while replicating the issue. In the file you see below exceptions
Request URL:
https://one-xxx.atlassian.net/rest/plugins/1.0/com.yasoon.jira.cloud-key
Request Method:
GET
Status Code:
404 Not Found
Remote Address:
Referrer Policy:
same-origin
Request URL:
https://one-xxx.atlassian.net/rest/plugins/1.0/com.yasoon.jira.cloud/marketplace
Request Method:
GET
Status Code:
404 Not Found
Remote Address:
Referrer Policy:
same-origin
On your browser open the Developer Tools, and in the Network tab, while you replicate the issue you will find below exceptions captured:
{code: 429, message: "Request has been rate limited"}
code: 429
message: "Request has been rate limited"
Cause
What is OneAtlassian?
OneAtlassian is a cloud demo site with pre-populated data that simplifies the demo setup for Marketplace Partners. To learn more about the OneAtlassian toolkit, please see Enhance your customer demo experience with One Atlassian.
Solution
Please reopen your PSD ticket logged with the Partner support team to help you install the necessary app.
If you were the reporter for the request logged with the PSD team to dedicate a demo instance, you can find the PSD ticket logged.
Navigate to the Atlassian support portal, and under Account → View Request, you should find the PSD ticket.
If you can't find a PSD ticket, contact the Jira support team. We can help you find a PSD ticket or seek the necessary assistance.
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