Unable to find or add Calendar Gadget in Jira

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

This KB article only applies to Jira Server environments. Official support for the Jira Calendar Plugin in Data Center environments is currently being tracked in the following Feature Request ticket: JRASERVER-74820 - Support Jira Calendar Plugin in Data Center

Problem

Unable to add Calendar Gadget in Jira by following the steps mentioned in this document: Adding the Calendar Gadget

This problem still exists even after you have tried to click Load all gadgets on the right side.

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Cause

The JIRA Calendar Plugin is not installed.

Resolution

  1. Go to Administration>Add-ons>Find new add-ons

  2. Search for "calendar"

  3. Install the "Jira Calendar Plugin"

  4. Once the Plugin is installed , go to Dashboard page and click on the "Add Gadget" button

  5. Search for "calendar" in the search box

  6. You will not see anything yet , so you have to click on the "Load all gadgets" at the right side

  7. Now you may see the "Jira Issue Calendar" available in search result which is on the right side

  8. Click on the "Add Gadget" button to add it into the dashboard

  9. Close the "Add a gadget" pop-up as it already added into the dashboard in the background

  10. Choose any project at the Project or Saved Filter then click Save

  11. Now you may see the calendar gadget appear on the dashboard

If your JIRA Server is unable to reach the marketplace, then you will need to download the .jar file from the marketplace. You can use this jar file to upload as add-on file locally as an Admin.

Updated on April 8, 2025

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