Unable to edit Epic Name from Epic's Issue Page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

While trying to edit the Epic, there's no Epic Name field shown in Edit screen.

Diagnosis

Diagnostic Steps

  • Check from the Issue Type Screen to verify whether Epic Name field is available in the screen

Cause

Epic Name field is not added to the Default Issue Type Screen.

Solution

Resolution

Add the Epic Name to the Default Issue Type Screen to allow users to edit Epic Name from Epic's Issue page.

  1. Navigate to Settings -> Issues -> Screen

  2. Look for the specific Screen used by the Epic. Epic will be using Default Issue Type Screen. The screen should be named like Project Key: Software Development Default Issue Screen. We can also check the screen used by Epic from the Project's configuration page.

  3. Click "Configure" beside the Screen used by the Epic/

  4. Scroll to the bottom of the page, search for "Epic Name" and add it.

  5. Try to edit the Epic again to see whether Epic Name is editable.

Updated on April 2, 2025

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