Unable to create work item in Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

While creating a work item user gets the error: 

Couldn't create the work item We're having some trouble creating the work item. Refresh the page and try again.

 This guide will explain how to troubleshoot this error when there is no indication from the error message what went wrong.

Diagnosis

Analyse error code in DevTools

Check dev tools and you will see the below call in Network tab with 500 response code:

  • issue?updateHistory=true&applyDefaultValues=false

  • Status Code - 500 Internal Server Error

  • Below is the response:

"errorMessages": [ "We can't create this issue for you right now, it could be due to unsupported content you've entered into one or more of the issue fields. If this situation persists, contact your administrator as they'll be able to access more specific information in the log file." ],
  • Here, even response does not pin points the root cause.

Checking create issue transition for workflow 

Since, the issue is not allowing to create the work item without indication then we should review the Create Issue transition from the workflow post function.

As per the document: Use post functions with the initial transition

Jira includes the following essential post functions that are specific to a workflow's initial transition and that are performed in this order:

  • Create the work item.

  • Fire an event that can be processed by the listeners.

Cause

The "Creates the issue originally"  is not the first post function on the list.

Solution

Review the workflow post functions and ensure "Creates the issue originally" post function should be at the first order.

If "Creates the issue originally" is not at first then adjust the postfunciton orders by arrow icons and keep this post function at first order as in below screenshot:

Jira workflow "Create" transition settings. Four post functions are listed, including "Create the issue," with controls to reorder them.  The "Create the issue" function is highlighted and should remain first.

After this, publish the workflow and you should be able to create the work item.

Additionally, there is a feature request to improve the error messaging for such issue which you can track below.

Updated on September 26, 2025

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