Unable to create user with a specific username in Jira Service Management with error 504 Gateway Time-out

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Observed HTTP Status code 504 - Gateway Time-out while trying to create a user from the Jira User Management console.

Diagnosis

  • AddUser.jspa page loads for sometime after clicking on the Create user button and eventually results in error 504

  • The following warning message appears in atlassian-jira.log:

    1 http-nio-8080-exec-2452 WARN XXXXX 907x4397268x52 xxxxxxx 0:0:0:0:0:0:0:1 /secure/admin/user/AddUser!default.jspa [w.view.taglib.IteratorTag] Value is null! Returning an empty set.

Cause

The error is thrown due to corrupted data in the user data cache and requires manual intervention to resolve it.

Solution

Refresh caches by full Jira restart (all nodes in case of DC): Full restart in Data Center is required because nodes with a corrupted cache will replicate it to other starting nodes, this means shutting down all nodes, validating the service is stopped, and starting them back up, a rolling restart will not resolve this issue.

This feature limitation is tracked in the Feature Request JRASERVER-66095 - Ability for Jira admins to flush internal caches

Updated on March 13, 2025

Still need help?

The Atlassian Community is here for you.