Unable to create Jira issue using an Incoming Mail Handler because the sender of the email is anonymous
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Issues are not created when using a Jira Incoming Mail Handler of type Creating Issues and Comments from Email. The desired effect is to create issues anonymously.
Diagnosis
The Jira Incoming Mail logs show the warning below:
1
2023-12-28 09:52:32,698+0000 WARN [Test] Caesium-1-1 anonymous Test Mail Handler Test Mail Handler[10100]: Sender is anonymous, no default reporter specified and creating users is set to false (or external user management is enabled). Message rejected.
Cause
This issue is happening because of the 2 reasons below combined:
the sender of the email is not associated to any Jira account (= anonymous sender)
AND the Jira Mail Handler is not configured to properly handle this situation
For the Jira Mail Handler to create a new Jira issue from an incoming email, it needs to set a reporter for this issue. If the Mail Handler is unable to find a valid reporter for that Jira issue, it will reject the email and will not create any Jira issue.
Solution
For the Jira Mail Handler to create issues from an anonymous sender the Mail Handler should be configured with either option described below:
Option 1:
Automatically create a new Jira user using the email address of the sender and create a new Jira issue with this user as the reporter
To do it:
Edit the configuration of the Jira Mail Handler in ⚙ > System > Incoming Mail
Tick the option Create Users
Save the Jira Mail Handler configuration
With such configuration, if the user creation by the mail handler is successful, you should lines like this in the Jira Incoming Mail Logs:
1 2
2023-12-28 10:26:32,384+0000 INFO [Test] Caesium-1-4 anonymous Test Mail Handler Test Mail Handler[10100]: Created user 'someuser@abc.com. 2023-12-28 10:26:32,683+0000 INFO [Test] Caesium-1-4 anonymous Test Mail Handler Test Mail Handler[10100]: Issue SCRUM-39 created
Option 2:
Create new issues using a default user as the reporter
To do it:
Edit the configuration of the Jira Mail Handler in ⚙ > System > Incoming Mail
In the Default Reporter field, select a user who:
who has Jira Application Access
and who has the permission to create issues in the project the Mail Handler is configured with
Save the Jira Mail Handler configuration
With such configuration, if the user creation by the mail handler is successful, you should lines like this in the Jira Incoming Mail Logs:
1 2
2023-12-28 10:42:32,386+0000 INFO [Test] Caesium-1-2 anonymous Test Mail Handler Test Mail Handler[10100]: Issue SCRUM-40 created 2023-12-28 10:42:32,389+0000 INFO [Test] Caesium-1-2 anonymous Test Mail Handler Sender(s) [someuser@abc.com] not registered in JIRA. Using configured default reporter 'defaultreporteruser'.
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