Unable to change password on AD user from within JIRA

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Unable to change password on AD server from within JIRA, using Read/Write connector.

Applies To: Windows Server 2008

Cause

The connection is not secure (SSL). To change password on AD user from within JIRA, you need to have a secure connection (SSL) established.

See this page for more information on how to change passwords on AD users from clients(JIRA).

Resolution

Setup SSL between JIRA and AD server

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.