Unable to associate Issue Types to Screen Schemes

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When attempting to associate Issue Types with Screen Schemes in the Issue Type Screen Schemes administration page, an error message of HTTP 503 Service Unavailable shows up. 

Further details of the message mentions a specific servlet: jsp.secure.admin.views.issuefields.screens.schemes.issuetype.configure.add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp is unavailable.

Diagnosis

The application logs contain a similar error stack:

1 2 3 4 5 6 7 8 9 10 11 12 13 <date-timestamp> <thread> ERROR [c.a.j.web.servlet.InternalServerErrorServlet] {errorId=<errorId>, interpretedMsg=, cause=java.lang.ClassNotFoundException: jsp.secure.admin.views.issuefields.screens.schemes.issuetype.configure.add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp, stacktrace=java.lang.ClassNotFoundException: jsp.secure.admin.views.issuefields.screens.schemes.issuetype.configure.add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1415) [catalina.jar:8.5.72] at org.apache.catalina.loader.WebappClassLoaderBase.loadClass(WebappClassLoaderBase.java:1223) [catalina.jar:8.5.72] at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:537) [catalina.jar:8.5.72] at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:518) [catalina.jar:8.5.72] at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:149) [catalina.jar:8.5.72] at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1071) [catalina.jar:8.5.72] at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:789) [catalina.jar:8.5.72] at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:688) [catalina.jar:8.5.72] at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:462) [catalina.jar:8.5.72] at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:388) [catalina.jar:8.5.72] at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:316) [catalina.jar:8.5.72] ...

This means that the specific file  jsp.secure.admin.views.issuefields.screens.schemes.issuetype.configure.add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp was not found.

Cause

Reviewing the last startup log, or an attempt to restart Jira will show the message below regarding removed system files under Modifications .

1 2 3 4 ___ Modifications ___________________________ Modified Files : None Removed Files : jsp/secure/admin/views/issuefields/screens/schemes/issuetype/configure/add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp.class

Something or someone outside of Jira either moved, or deleted the missing file.

Solution

  • Navigate to your instance's <Jira-install-directory>/atlassian-jira/WEB-INF/classes/jsp/secure/admin/views/issuefields/screens/schemes/issuetype/configure/

  • Check if the file add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp.class exists, and has appropriate ownership, and permissions for the user running Jira.

    • If the file exists in the loction:

      • Check if it has missing ownership/permissions

      • Update the ownership/permissions accordingly

    • If the file doesn't exist in the location:

      • Download and extract an installer file of Jira.

      • Extract the contents to a folder or directory.

      • Copy over the file <Jira-install-directory>/atlassian-jira/WEB-INF/classes/jsp/secure/admin/views/issuefields/screens/schemes/issuetype/configure/add_002dissue_002dtype_002dscreen_002dscheme_002dassociation_jsp.class

        • From the fresh download of the installer

        • Onto your own Jira instances' <Jira-install-directory>/atlassian-jira/WEB-INF/classes/jsp/secure/admin/views/issuefields/screens/schemes/issuetype/configure/

      • Restart Jira

Updated on March 10, 2025

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