Unable to archive components
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Sometimes you're unable to archive components. This problem happens because the Component Lead doesn't exist or is unreachable. Normally, when we delete a user in Jira, the bond between the user and the component leadership is unmade. However, if the user was deleted directly from the database (or is unreachable due to other reasons), several checks (including the unmaking of the component bond) aren't done.
Diagnosis
When you try to archive a component, you get a red exclamation mark followed by a retry button (like below):

Solution
Edit the component (Actions > three dots > Edit) and change (or remove) the component lead, after this, you should be able to archive the component.


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