Unable to Add New Resolution in Workflow

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Users are unable to add a new resolution in Jira workflows. The page loads but does not respond, preventing the addition of the resolution.

Diagnosis

The issue can be diagnosed by checking the atlassian-jira.log. You may find an error message similar to the following:

1 2024-10-18 17:07:43,205+0200 https-jsse-nio-443-exec-48 ERROR [o.a.c.c.C.[.[localhost].[/].[action]] Servlet.service() for servlet [action] in context with path [] threw exception [com.atlassian.jira.exception.DataAccessException: org.ofbiz.core.entity.GenericEntityException: while inserting: [GenericEntity:Resolution][sequence,313][name,admin ][description,][id,10202] (SQL Exception while executing the following:INSERT INTO resolution (ID, SEQUENCE, pname, DESCRIPTION, ICONURL) VALUES (?, ?, ?, ?, ?) (Duplicate entry '10202' for key 'PRIMARY'))] with root cause java.sql.SQLIntegrityConstraintViolationException: Duplicate entry '10202' for key 'PRIMARY'

Cause

When adding a new resolution, an entry is added to the resolution table. The ID for this entry is retrieved from the sequence_value_item table, which holds the next ID value for each Jira table. After each insert operation, this ID is incremented by 1. However, in this case, the ID value retrieved from sequence_value_item for the resolution table already exists in the resolution table, leading to the error:

1 java.sql.SQLIntegrityConstraintViolationException: Duplicate entry '10202' for key 'PRIMARY'

Solution

To resolve this issue, ensure that the ID value associated with the resolution table in the sequence_value_item table is not already present in the resolution table. Follow these steps:

  • Stop Jira.

  • Take ba ackup of the Jira database.

     Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.

  • Run the following SQL Query:

    1 UPDATE SEQUENCE_VALUE_ITEM SET SEQ_ID = ((SELECT MAX(id) FROM resolution) + 10) WHERE SEQ_NAME = 'Resolution';

    The query should work for all Databases.

  • Start Jira.

Updated on March 19, 2025

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