Resolve Comment Management Issues in Specific Status - Jira Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

You are unable to add, edit, or delete a comment when the work item is in a specific status

Environment

Jira Software Cloud

Diagnosis

  1. You are unable to add, edit, or delete comments on some work items (probably belonging to the same status)

  2. You have the required permissions related to comments in the project permission scheme.

  3. When trying to add, edit, or delete a comment, a pop-up error message appears

    Error message

    We couldn't save your comment It might be empty or have invalid formatting. If you copy-pasted, try removing the formatting and adding it directly in the editor
    Error message: "We couldn't save your comment" It might be empty or have invalid formatting. If you cop-pasted, try removing the formatting and adding it directly in the editor.
  4. Generate the HAR file, we notice the following exception

{ "errorMessages": [ "You can not delete the comment as the issue is in a non-editable workflow state." ], "errors": {} }

Solution

  1. Navigate to your Project Settings and select Workflows.

  2. Choose Edit Workflow for the specific Work Item Type as text

  3. For the Linked Status, where you encounter the issue, select View Properties

  4. Confirm that the jira.issue.editable property is set with the value False.

  5. To fix, either delete the property or set the value to True.

Workflow step properties page showing an example with the property key jira.issue.editable set to False

Updated on May 7, 2025

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