Trying to display Insight Objects pops up error "Failed to retrieve references"

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When trying to display one specific Insight object, the error "Failed to retrieve references" pop up.

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When checking in the atlassian-jira.log file for the full stack trace we see the following:

1 2 3 4 5 6 7 8 9 10 2022-02-25 10:48:50,670+0000 http-nio-8080-exec-29 ERROR admin 648x1229x1 v77td4 172.29.215.226,172.50.0.2 /rest/insight-am/1/assets/MOS-11/outboundreferences [i.r.core.rest.ExceptionErrorMapper] Oops java.lang.IllegalStateException: this.summary must not be null at io.riada.assetmgt.ticket.rest.model.IssueModelMapperKt.toTicket(IssueModelMapper.kt:31) at io.riada.assetmgt.ticket.service.TicketServiceJiraImpl.findTicketsByObject(TicketServiceJiraImpl.kt:59) at io.riada.assetmgt.asset.service.AssetReferenceServiceImpl.getOutboundReferences(AssetReferenceServiceImpl.kt:54) at io.riada.assetmgt.asset.rest.AssetResource.getOutboundReferencesByKey(AssetResource.kt:174) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:566)

Diagnosis

The stack trace indicates, that we are looking for outboundReferences and specifically for Jira tickets, that are connected to this object. One of these tickets seem to be missing a summary.

However, when checking on tickets connected to this specific Insight object, all assigned tickets (if there are any) have a summary.

Solution

Jira is not only checking for the references of the directly connected tickets, but also for the tickets connected to other objects that relate to this object. As the summary is a required field in Jira, this field needs to be fixed anyway in order to prevent other unexpected errors.

As the ticket can still be displayed in Jira, you can just search and edit the ticket.

In order to find all tickets without summary there are 2 options:

Option 1 JQL Search

For the JQL search, go to Issues>>Current Search , select Advanced and enter "summary is EMPTY" as query

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Option 2 Database Query

Second option would be to run a database query as follows:

1 2 3 SELECT p.pkey, j.issuenum, j.summary, j.creator FROM jiraissue j, project p WHERE (j.summary IS NULL OR j.summary = '') AND j.project = p.id;
Updated on April 11, 2025

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