Troubleshooting missing email notifications for user mentions in Jira and JSM Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

In Jira Cloud, users mentioned with @ tags should receive email notifications. However, there are cases where they don't. This article will explore a few causes.

Cause

Example

Emily mentions Robert in a Jira work item, but Robert doesn't receive an email notification.

Such a scenario may occur if:

  1. Robert disabled email notifications.

  2. Emails to Robert's email address were suppressed.

  3. Emily doesn't have Browse users and groups global permission.

Solution

As a troubleshooting measure, please ensure Robert's inbox accepts emails from other email addresses (including those with domains different from Robert's). Additionally, be sure to check Spam and other inbox folders (Notifications, etc.).

Scenario 1: Robert disabled email notifications

If Robert has disabled his email notifications, he won't receive any email alerts from Jira Cloud, including those for mentions. Here's how Robert can check and adjust his email notification settings:

  1. Robert should log in to the Jira Cloud site, where Emily mentioned him.

  2. Select the profile picture on the top right and select Personal Settings.

  3. Under the Email notifications for work item activity section, he should ensure that Send me email notifications is selected and that the checkboxes under Get email updates for work item activity when: are selected appropriately.

  4. If the Someone mentions you checkbox was unchecked, he should select it and Save changes.

Scenario 2: Emails to Robert's Email Address Got Suppressed

If emails to Robert's email address were suppressed, he would not receive any emails from Jira.

In this case, please contact Atlassian Support to get Robert's email address unsuspended.

Scenario 3: Emily doesn't have the Browse Users and Groups global permission

If Emily does not have the Browse Users and Groups global permission, she won't be able to trigger email notifications for Robert when she mentions him. Here's how Site Admin or Jira Admin can grant Emily the necessary permission:

  1. Log in to the Jira site in question.

  2. Choose ⚙️ > System.

  3. Select Global Permissions.

  4. Scroll to the bottom of the page to find the Add Permission section.

  5. Select the Browse Users and Groups in the Permission dropdown.

  6. In the Group dropdown list, either:

    • select the group Emily is a member of

    • select Anyone to grant permission to users who aren't logged in (not recommended)

If you wish to add Emily to a group that already grants Browse Users and Groups global permission:

  1. Check that group's name in your Jira site under ⚙️ > System > Global Permissions.

  2. As a Site Admin, log in to your Atlassian Admin Hub and select your organization if you have more than one.

  3. Select the site's name and URL to open the Admin for that site, then select Groups (or select Directory > Groups).

  4. Select the group that you want to add users to.

  5. Select Add group members and search for the users you want to add.

  6. Select Add users.

Updated on May 8, 2025

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