Transitioning an Issue Results in a Workflow Error

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

You attempt to transition an issue to a new status and then...

The following appears:

1 Could not move to history step for #175444: root cause: while inserting: [GenericEntity:OSHistoryStepPrev][id,373216][previousId,373215] (SQL Exception while executing the following:INSERT INTO public.OS_HISTORYSTEP_PREV (ID, PREVIOUS_ID) VALUES (?, ?) (ERROR: duplicate key value violates unique constraint "pk_os_historystep_prev"))    

Possible Causes

  1. There is a value in both the os_historystep and os_historystep_prev tables which are the same.

Possible Resolutions

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. In your os_historystep_prev table, delete the entire row with the max(id), restart JIRA, and attempt the transition again.

  2. If you have scripts running in any conditions, validators or post functions, make sure they haven't any errors. Delete them to see if this fixes the issue.

    If your case is #1, use this command to delete the row

    1 delete from os_historystep_prev where id = <id pertaining to the error>;

    ℹ️Please remember torestart JIRA if making changes to the database.

Updated on April 15, 2025

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