The search index does not update when users create an issue

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The search index does not update when users create an issue, even after several hours.

Diagnosis

  • A newly created ticket does not show up in any queries.

  • When re-indexing manually, the newly created issue starts showing up in queries normally.

  • Missing IssueReindexFunction post function in the issue's affected workflow

Cause

Legacy versions of JIRA did not have the IssueReindexFunction post function available for workflows.

Workaround

Add the "Re-Index Issue" post function to the Create Issue transition of the affected workflow. If you need to find all affected workflows, run the following SELECT against JIRA's database:

1 select * from jiraworkflows where descriptor not like '%IssueReindexFunction%';

This problem is also discussed in JRASERVER-32508 - Custom event on "create issue" transition and Indexing problems.

Updated on April 11, 2025

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