The REST API call for the user picker does not retrieve any data.
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
REST API to find the users for user picker does not retrieve any results, even though the user executing the REST API is a Jira administrator. Here is an example of using the endpoint to get user picker details.
As per our REST API documentation the end point is “GET /rest/api/2/user/picker?query”.
Environment
Jira Data Center on any version from 8.0.0
Diagnosis
When utilizing Postman to send a REST API call to the above endpoint, no errors are thrown. Although an HTTP status code of 200 is returned, no user details are included in the response.

Cause
The user’s email visibility has been configured as HIDDEN in the Jira general settings. By default, the email visibility isPUBLIC.
User email visibility Controls how users' email addresses are displayed on the user profile page.
- PUBLIC - email addresses are visible to all.
- HIDDEN - email addresses are hidden from all users.
- MASKED - the email address is masked (e.g. 'user@example.com' is displayed as 'user at example dot com').
- LOGGED IN USERS ONLY - only users logged in to Jira can view the email addresses.
Default: PUBLIC
The REST API calls do not return any results if the user email visibility is set to Hidden in Jira, and this behaviour is intentional. It provides an additional measure of privacy.
Solution
One potential workaround in this scenario would be to modify the User email visibility setting to Masked.
From the top navigation bar select Administration
> System.
Select General Configuration to open the Administration page.
Click the Edit Settings button and change the User email visibility to Masked:
Below is a sample response when the user email visibility is set to MASKED.

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