"The provided attachments path does not contain a sub-directory called" error during Project Import in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When performing a project import, in the verification screen before the import the following error will be shown in the Attachments section:

"The provided attachments path does not contain a sub-directory called "XX". If you proceed with the import the import attachments will not be included."

The same error is shown in catalina.out and atlassian-jira.log log files.

Cause

The attachments directory may have been copied over to <JIRA_HOME> /data/attachments folder but should have been copied over to <JIRA_HOME> /import/attachments.

When you first begin a project import it will provide the import attachment path:

(Auto-migrated image: description temporarily unavailable)

Resolution

Copy the attachments from /data/attachments to /import/attachments.

Updated on April 11, 2025

Still need help?

The Atlassian Community is here for you.