The Profile Edit Details button is missing for users

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The pencil icon button for the Details section is hidden when navigating to the users avatar in the upper right > Profile. When using the internal directory for user management, when users navigate to the avatar in the upper right corner and choose the Profile option there should be a pencil icon in the right side of the Detailssection. This option will allow the user the ability to self-serve in changing their full name, email address and password.

(Auto-migrated image: description temporarily unavailable)

Environment

Jira 8 and higher

Cause

This option for the internal directory can be controlled by the External Management setting within System > General Configuration > Edit Settings. If this setting is set to ON it will disable this button.

Solution

To re-enable this button, set the External Management setting within System > General Configuration > Edit Settings to OFF.

⚠️ This will also turn back on the "Can't access account?" hyperlink on the login form. If it is desired to hide this option but allow users the ability to edit their Profile details, please see Remove the Can't access your account? link from Jira server for an alternative solution using CSS within the Announcement Banner to hide that option from the login form.

Updated on April 8, 2025

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