The Jira search page shows the error "XXXX does not exist or you do not have permission to view it"
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to view filters or search results, you receive an error within a red box similar to the error below:


Cause
Possible causes for the error above:
The user is not logged into the Jira system.
The user does not have the appropriate project permissions to view the Fields (this is only for the case where the error is complaining about a field)
The user does not have the permission to view the Filter. You are not the owner or the filter or it has not been shared with you (this is only for the case where the error is complaining about a filter)
The referenced Custom Field is hidden in the Field Configuration (this is only for the case where the error is complaining about a field)
The Custom Field does not have the appropriate Context Configuration. (this is only for the case where the error is complaining about a field)
Resolution
Ensure that the user is logged into the Jira application
Ensure the user has the the proper project permissions - these can be verified with the JIRA Admin Helper and edited as per Managing project permissions.
Ensure that the filter has been shared with the appropriate user as detailed in Managing shared filters.
If the owner of the filter no longer exists:
As of JIRA 4.4, JIRA administrators can change the filter's owner in Managing shared filters.
Pre JIRA 4.4, an administrator will need to re-create and reset the user's password. They can then log in and manage the filter.
Verify the field is not hidden for the project's Field Configuration scheme. We detail how this works in Specifying field behavior.
Go to the Custom Field administration area and find the affected field.
Click on the Cog icon (far right) to Configure and then Edit configuration to add the appropriate context (the field needs to be available in the project or issue type which is used inside the Issue Search query)
Take a moment to go itCog > Edit to make sure it has a Search Template other than None.
If the field is LOCKED, you'll need unlock it first: Unlock a LOCKED Custom field in JIRA
For more information around Jira Field Context Configuration, you can refer to the documentation Configuring custom field contexts
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