The Jira process starts but cannot be accessed, no output in atlassian-jira.log
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The Jira process can be start and stopped but Jira itself is inaccessible while nothing is ever written to atlassian-jira.log
The following appears in the catalina.log on Linux or jirasoftware(service-id)-stderr.(date).log on Windows
1
2
3
24-May-2019 10:25:06.431 SEVERE [localhost-startStop-1] org.apache.catalina.startup.ContextConfig.configureStart Marking this application unavailable due to previous error(s)
24-May-2019 10:25:06.434 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.startInternal One or more components marked the context as not correctly configured
24-May-2019 10:25:06.448 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.startInternal Context [/] startup failed due to previous error
Cause
web.xml, located under the conf directory in the Jira installation folder, is invalid.
Resolution
Review web.xml and fix the discrepancy. If nothing is immediately obvious download the Jira installer zip file and copy the standard web.xml file into the conf directory.
Was this helpful?