The issue XXX has been created but is not currently visible on the board
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Creating an issue on aboard gives the following notification on the top-right of the screen.
1
The issue XXX has been created but is not currently visible.
Diagnosis
The following steps were done to reproduce this behavior:
We have two projects Test and Test 2:

A board will automatically be created for Scrum projects but it has the same effect as creating a brand new board with the project as the only filter. Your board config will look like this:

The Scrum Board is created. Click "+ Create issue" > Open in Dialog (so you can edit a bit more of the ticket on creation):

Take note that we are creating an issue in the Test 2 project.

The message is shown on the board:

The reason being the Filter Query only includes Test and not Test 2.
Cause
The Filter Query does not include the project that you were trying to create issue at. In this example, it only includes Test and Test 2 is not present.
While the above was a very simple example to cause the message to be displayed, the key element is that the created issue does not meet the criteria determined by the Filter Query.
Solution
Resolution
You may modify the board filter (or create a new board) so the new issue is included in the query. On this example you'd have to add Project TESTTWO to it.
Ensure that the sprint custom field is set to Global Context to reflect the changes on all the projects that you have in your instance. If you set it to only certain projects, then it will cause the notification message to appear.
For more information about Global Context, please refer to the documentation Custom fields with global contexts
To check if the Sprint field is configured with Global Context, go to the page ⚙ > Issues > Custom Fields, search for the Sprint field, and check the Available Contexts column:
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