Suggestions not working for User Picker field in Jira Server
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When trying to assign users to roles in the Project Role page or other places where a JIRA application has an autocomplete field for users, the field does not provide username suggestions.
Cause
Sometimes this problem can be related to insufficient Global Permissions. Additionally, sometimes the User Picker field can automatically turns itself off when a high number of users is detected (such as when connecting to a large LDAP repository).
Resolution
For Issues with Global Permissions
Make sure that the logged in user has allow browse user permission for whatever groups they are in - especially in the jira-users group.
To Allow the permission, do the following:
Login to the JIRA application as the Admin.
Go to JIRA Administration > System > Security: Global Permissions
Set the permission for Browse User permission to allow jira-users group. Find the official documentation for allowing this permission here.
For Issues with high number of users detected
Determine the number of users in your system by either checking
Administration > Users
and taking note of the maximum value or the following SQL query:1
select count(*) from cwd_user;
Change the Advanced JIRA applications configuration property:
1
jira.ajax.autocomplete.userpicker.limit = XXXXX
where "XXXXX" is greater than the number of users from Step 1.
If necessary, restart the JIRA application.
Was this helpful?